Hunting the Keyboard Shortcut

Recently while in the mood I decided to upgrade my Thinkpad X280  from Ubuntu 16.04 LTS (for which it had the approval) to more current Ubuntu 18.04 LTS.

That also meant that I’m back on Gnome Shell which I’m not really a fan of, I was able to get my hands dirty on it when I was using Fedora a lot and it was new (“Gnome 3”) and well, I found it a bit rough.

However for the UI now – that is some years later – as it has been tailored for the Ubuntu flavor I find it quite acceptable (not because of Ubuntu but just the package is fine). I merely had some issues with the Laptop on Ubuntu 18.04 which most likely are not exactly related to Ubuntu 18.04 in specific, I’d like to write down about in this blog post:

ThinkPad Pro Docking Station with ThinkPad X280 on Ubuntu 18.04

First of all with the Lenovo ThinkPad Pro Docking Station (the USB-C one where you put the Laptop into and the USB-C docks from the left) I have in use there were some problems with my USB Keyboard on the docking station – it was just not enabled. This can be checked if it has a Num Lock LED and pressing Num Lock should toggle the light on and off. If you’ve got a keyboard with Num Lock LED at least in desktop mode this is a good check, while booting this is no check at all because there is no Num Lock LED going on, at least not for me. Apart from input devices via USB (I only have input devices on the dock at boot time normally) everything else worked with the docking station out of the box: Video via VGA port and Ethernet adapter.

It took me quite some time until I learned about having some BIOS settings influencing USB connectivity at boot time. Right now it works since some days in an acceptable manner (boot within dock and outside, suspend, take out, use out, suspend, put in etc.) and two BIOS settings I could identify I need to have for this working:

  1. Config / Thunderbolt (TM) 3 / Security Level: “No Security” (while having the Thunderbolt(TM) device “Disabled” for support in Pre Boot Environment)
  2. Config / USB / USB UEFI Bios Suppport: “Enabled”

As it was quite a bit of change here change there, this is perhaps not all settings, but I was using these. There is a warning to not enable a specific Linux one (which I had enabled to try it but disabled it quickly again as it is reported to brick Thinkpads on change (!)) and quite some users are reporting problems with the docking station regarding video which never was an issue for me from the beginning.

From my subjective impression, it was more an out-of-the-box experience while on Ubuntu 16.04, but it might be just since I upgraded the OS I perhaps wanted to finally get this into order, so this might be useful regardless of which Ubuntu version (or the underlying Kernel version).

Hunting the Keyboard Shortcut in the Dconf

While it was not enough to have actual keyboard connectivity problems (which really suck as the X280 has only one USB port left for use when in the dock, so I could only have mouse or keyboard working) with the Ubuntu upgrade to 18.04 I even “lost” one of the main keyboard shortcuts you have in browsers / editors / programming: CTRL+F to find in page / document / editor.

Finally I found a way to trouble-shoot this quickly, it works for any system that supports the dconf utility. With dconf dump it is possible to search for keyboard shortcut sequences, in my case CTRL+F is a “f” there, it can be quickly (and case independently) searched for:

$ dconf dump / | grep -i 'f'
move-to-workspace-9=['f']

Finally I could locate the culprit. Finding out under which configuration path needs a sed filter with a little “program” (examples of case insensitivity and hold buffer):

$ dconf dump / | sed -n '/^\[.*\]$/h;/f/I{x;p;x;p}'
[org/gnome/desktop/wm/keybindings]
move-to-workspace-9=['f']

It then shows the path to the setting above the match. The rest was merely straight forward to edit out that keyboard shortcut which I have no idea at all how it ended in there:

$ dconf write /org/gnome/desktop/wm/keybindings/move-to-workspace-9 "['disabled']"

I don’t know how I was finally able to check that one, I actually was trying out the Ubuntu Keyboard Shortcuts Troubleshooting guide in the Wiki which made a good impression to me as it allowed me to check if/what is actually working with my keyboard, however it’s more on the event level which turned out working for me. And then I needed to look further and with one of many shattered Stackoverflow postings, eventually another time the hint on Dconf Editor and that it has Keyboard Shortcut configuration “somewhere there” did let me fiddle with searching within the shell.

In my opinion a recommended utility to install on Ubuntu 18.04 LTS when using the Gnome Shell for sure is “gnome-tweaks” also known as Tweaks or Gnome Tweaks Tool.

Advertisements
This entry was posted in Hakre's Tips and tagged , , , , , , , , , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.